Side by side not cooling My GE profile side by side is leaking some water and now is not cooling. The temperature reads 27degrees in freezer and 51 degrees in refrigerator. Can not hear compressor only hear fan turning. I change the temperature on the electronic touch pad but it goes back to previous teperature. What is wrong?

asked by

on

29 Dec, 2006

  • 68%
    Solved this issue
  • 88min
    Time to fix
  • 70%
    Recommend to DIY
Need a faster answer?
Couple of things... first need to see if the compressor is really hot to the touch and "clicking" on and off every 3-5 minutes due to high heat (trying to start). If that's what is happening you likely have a "start device" failure (little box on the side of the compressor). If the box is white in color and you pull it off and it makes noise when you shake it (along with little bits of debris falling out) you know it's bad. They make a kit to fix that known problem. If the compressor isn't trying to start but actually runs quietly... check that the cooling coil isn't all iced up preventing proper air flow inside the cabinet (take the panel of the rear inside of the freezer section to check it). If that is all a block of ice basically you likely have a defrost cycle problem (defrost t-stat bad, defrost timer bad, etc.). Other than that you should have a little fan right above the coils to move air around, if the compressor is running and the compressor fan (called condensor fan) is running then this fan (called evaporator fan) should also be running to move the cold air around. If that fan is dead then you will have a nice cold coil but no air flow over it to cool the rest of the refer/freezer properly. Let us know what ya find out.
SHARE YOUR EXPERIENCE
  • Were you able to resolve it?
    Yes No
    Awesome !
    Ok
  • How long did it take to fix?
    Good to know
  • Is it better to DIY or Repair?
    DIY Repair
    Great
    Got it
Instant Repair Help
over the Phone or Video