No water from dispenser My Kenmore Mod # 106.54382300 has no water coming from the dispenser, the ice maker is still working fine, but the accelerator switch keeps beeping on and off when we open the door (might be related).

asked by

on

24 Nov, 2006

  • 62%
    Solved this issue
  • 105min
    Time to fix
  • 70%
    Recommend to DIY
Need a faster answer?
If the ice maker is still working then water of course isn't an issue. The water dispensor has a solenoid valve that opens to let water flow... do you hear a "click" from the back of the frige when the water lever is pushed? If not, the valve is likely bad. Another possibility is the switch behind the water lever itself is not being pressed hard enough or even broken, see if you can press the switch with your finger up inside behind the lever area (flashlight needed to see up there). If that lever isn't hitting the switch it won't work of course but it could be a bad switch too. Sometimes the little plastic pins that hold the switch in place get broken by slamming a glass into the lever over time. In other words the switch is fine but just hanging inside the door area never to be hit by the lever again. I would be good to check it by pulling the cover off that are and visually inspecting the whole back side of the lever area/switch are for broken parts. The link below may help you with parts and diagrams to see the unit better. http://www.partselect.com/KenmoreModels.aspx?ModelNum=106.54382300&searchTerm=
SHARE YOUR EXPERIENCE
  • Were you able to resolve it?
    Yes No
    Awesome !
    Ok
  • How long did it take to fix?
    Good to know
  • Is it better to DIY or Repair?
    DIY Repair
    Great
    Got it
Instant Repair Help
over the Phone or Video