Recently changed my spark plugs and washed my air cleaner for my 2005 roadking classic and now it runs kind of rough. The plugs come pre gapped and I made sure the air cleaner was dry before install. recently changed my spark plugs and washed my air cleaner for my 2005 roadking classic and now it runs kind of rough. The plugs come pre gapped and I made sure the air cleaner was dry before install. Also I pulled the new plugs and checked them and there is a light grey coating on them. What is the problem and best way to fix it?

asked by

on

21 Jun, 2015

  • 63%
    Solved this issue
  • 109min
    Time to fix
  • 69%
    Recommend to DIY
Need a faster answer?
Hi Nicholas, did you use 6R12 spark plugs gapped at 040"? and the usual suspects are:
1. Spark plugs in bad condition or partially fouled.
2. Spark plug cables in bad condition or leaking.
3. Spark plug gap to close or to wide.
4. Faulty ignition coil, module and or sensor.
5. Battery nearly discharged.
6. Damaged wire or loose connections at battery terminals especially the negative cable at "BOTH" ends, ignition coil, or plug between ignition sensor and module.
7. Intermittent short circuit due to damaged wire insulation.
8. Water or dirt in fuel system, carburetor or filter.
9. Fuel tank vent system plugged or carburetor vent line closed off.
10. Carburetor controls misadjusted.
11. Damaged carburetor or intake seals.
12. Loose or dirty ignition module connector at crankcase.
13. Faulty MAP, CKP, and or CMP sensors.
14. Incorrect valve timing.
15. Weak or broken valve springs.
16. Damage intake or exhaust valve.
For a prime suspect please visit website below.
Good luck and have nice day.
Harley Diagnostic Codes 04 to Present
SHARE YOUR EXPERIENCE
  • Were you able to resolve it?
    Yes No
    Awesome !
    Ok
  • How long did it take to fix?
    Good to know
  • Is it better to DIY or Repair?
    DIY Repair
    Great
    Got it
Instant Repair Help
over the Phone or Video