2000 Jetta sputters and shakes...doesn't go above 40 mph...Error codes P0300,P0301,P0302,P0303,P0304 Hi, I have a 2000 VW Jetta with 96k. In the recent past, I was driving it in this fashion: turn it on, let it "Warm up" for 5 minutes, then it would drive fine. If I didn't let it sit and idle beforehand, it would shake and sputter, and not go above 10 mph. Hypothetically, if I turn it on, and just very slowly go down the road, even with my gas pedal down, I'd be puttin' down the road at 5 mph for about 5 minutes, and then all of a sudden it would "kick in" and drive fine (able to go highway speeds and accelerate normal). It failed an emissions test and has the check engine light on, showing these codes primarily: p0300 p0301 p0302 p0303 p0304. Other problems (connections?): I seem to lose about 1/4 cup of coolant in a normal driving week. It over heats fairly quickly as it idles. What I've Tried: New: Spark Plugs, fuel filter, air filter, cleaned the MAF, cleaned throttle body, put engine treatment in gas tank, replaced coolant sensor, checked water pump flow rate, checked for vacuum leaks (found one and fixed it) Any and all help is appreciated. Thank you.

Need a faster answer?
You have a random misfire issue follow the link for info on this problem. Problem 6 Engine Stalls Misfire Code Cylinder Misfire
Was this answer helpful?
Yes
No
Thank you for your feedback!
Instant Mechanic Help
over the Phone or Video
Check Icon Get Instant Help
Check Icon Save hundreds of $$$
Check Icon Available 24/7