Yamaha 650 v star loss of power when accelerating

Need a faster answer?
Hi, Anonymous and the usual suspects are:
1. Severely discharged or a damaged battery, should have 12.5 volts or better and be able to pass a load test if necessary.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Spark plugs in bad condition or partially fouled.
4. Spark plug cables in bad condition and leaking.
5. Spark plug gap too close or too wide.
6. Faulty ignition coil, module, and or sensor.
7. Loose, dirty, or corroded ignition module connector at crankcase.
8. Faulty CKP or CMP, MAP, ETS, ATS, TPS, O2 sensor.
9. Intake air leak.
10. Water, dirt, or rust in the fuel system, carburetor and/or filter.
11. Fuel tank vent system plugged or carburetor vent line closed off.
12. Vacuum line from intake manifold to fuel valve is broken, cracked, pinched, or missing.
13. Carburetor controls misadjusted.
14. Damaged carburetor.
15. Incorrect valve timing.
16. Weak or broken valve springs.
17. Damaged intake or exhaust valve.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
Losing power on Vstar 650
http://www.ymhmotoboard.com/topic/v-star-650-custom-losing-power
98 00 Yamaha XV650 Star Service Manual XVS650 Moto Data Project
OEM parts for Yamaha
http://www.starmotorcycles.com/assets/service/manuals/2003/LIT-11626-16-05_22.pdf
Was this answer helpful?
Yes
No
Thank you for your feedback!