Maytag centenial won't spin maytag centenial won't spin

asked by

on

18 Jun, 2012

  • 69%
    Solved this issue
  • 90min
    Time to fix
  • 69%
    Recommend to DIY
Need a faster answer?
Your going to check the belt and pulley inside the machine but let me warn you first, this is a knuckle busting nightmare of a machine, and if your not fond of the idea of bleeding, grease and pain, call a repair company. I'll post a few examples to help you make your mind on the topic.
Belt wore out

Had to remove pump-not easy. Nothing wrong with pump, but had to trash it to get it off the motor shaft, so I had to replace it, too.

Pop up top of cabinet and remove front panel. (I leaned unit back against a wall to facilitate internal access once panel was removed.)


Remove motor assy - 4 screws & connector.

Remove 3 pump screws (torx) and 2 hoses. Pry pump off motor shaft (not easy). I used a heat gun to help expand the plastic fitting on the motor shaft.

Remove old belt, put on new belt. (Do not use automotive belt-this belt is designed to slip because it also spins the tub. The tub will not spin when it's full of water, and the pump will not pump the water if the tub is bogging down the pump. Plus, you will probably overheat the motor.)

Press new pump back on motor shaft (advise not to re-use old pump as seals were probably damaged by removal process.)

Caution: Pressing pump onto motor shaft may cause pump rotor to bind in housing. Try to press it on a little too far so you back off slightly.

Replace pump screws.

Replace motor, giving attention to belt alignment.

Replace motor screws and connector.

Re-attach hoses on pump.

Button up cabinet.

Done.

The hardest part was removing the pump. If not for that, it would have been a 15-min, $20 repair.

Because I felt it wise to replace the pump also, it was a $70 repair.

#2


Drive pump leaked

It took some trial and error but overall not a difficult project.

1. Take the front covers off.
2. Undo the pully spring to loosen belt
3. Remove belt off idler pulley wheel and free up belt from the large wheel.
4. Disconect the wiring harness and the hoses.
5. Undo the motor mounting bolts (4)
6. Take motor out of washer and remove the 3 screws holding the pump to the motor.
7. The pump had melted to the shaft and required I chisel the pump off of the shaft.
8. Attach new pump paying attention to where the belt is positioned.
9. Reattach the motor bolts, hoses, and wiring harnes.
10. Attach the belt and test the pump.
11. Put the front back on

SHARE YOUR EXPERIENCE
  • Were you able to resolve it?
    Yes No
    Awesome !
    Ok
  • How long did it take to fix?
    Good to know
  • Is it better to DIY or Repair?
    DIY Repair
    Great
    Got it
Instant Repair Help
over the Phone or Video